SCCM 2012 R2 CU2 Can't Edit WMI Query Code in Report Builder

Advertisement

I first posted this in the SCCM but the issue is not solved so I thought I'd try here in the SQL Reporting forum. Original thread here: http://social.technet.microsoft.com/Forums/en-US/b0a6ca3d-7471-4b49-8447-7403a65c2ec0/sccm-2012-r2-cu2-cant-edit-wmi-query-code-in-sccm-reports?forum=configmanagergeneral
I'll repost info here to make this easier.....
I built a new SCCM 2012 R2 CU2 suite on Server 2012 R2. This also uses SQL 2012 SP1 CU6. This suite has 4 servers: site server, two for WSUS and secondary DPs, and SQL. This problem is true for the built in reports and my custom reports. Our SQL guy has
been helping me a lot but we've gotten nowhere. I can run a report. I can open one in edit mode after it prompts me for credentials. It loads Report Builder 3.0. But when I go to a dataset/query, enter credentials, and try to open it, I get a popup that
says "Unable to connect to data source. 'AutoGen_5C6358F2_yayak..." When I click on details it says "The target principal name is incorrect. A connection was succesfully established with the server, but then an error occurred during the login
process.  (SSL Provider, error: 0 -The target principal name is incorrect.)" In SQL Reporting Services Config Manager the paths for Web Service URL is
http://ip.ip.ip.ip:80/ReportServer_SC01 and for Report Manager URL:
http://ip.ip.ip.ip:80/Reports_SC01. A domain account is used to login. This happens when you r-click a dataset and select query to edit the code of a dataset, ie, when query designer tries to open up. It happens
in both Admin Console and when using the Report Manager URL within SQL SSRS. All other functions of using edit mode of a report work fine.
Ben JohnsonWY

Advertisement

When I do that, browse is dimmed out.
But, if I deselect "create a data set" and click "choose an existing dataset in this report..." there is no data connection at the end.
But if I don't use report builder and instead use IE to browse to my ConfigMgr_ABC, I do see the connection at the end: {123...}.
This problem is on a network that is not on the 'net, so it's hard to do screen shots, so I'll reproduce this problem step by step:
I pick a report to edit, it doesn't matter which one.
If I try it in Admin Console, I right-click, Edit the report, it asks me for a login, I login, then I get a popup that says "Cannot continue. The application is improperly formatted. Contact the vendor for assistance. I click the Details button and
get a long set of text but the key part is "Your web browser settings do not allow you to run signed applications." This msg didn't appear before, so something changed, so I will investigate. I think it used to give a SPN error.
If I use IE within report builder and navigate to whatever report, click open, everything works, except, when I click on Dataset0 (the key one I normally need to edit), click query, it prompts me for a login and no matter which one I use, i get a popup that
says "unable to connect to data source 'AutoGen_123...'". If I click details I get "the targe principal name is incorrect. A connection was successfully established with the server, but then an error occurred during the login process. (provider:
SSL Provider 0-The target principal name is incorrect.)
Ben JohnsonWY

October 11, 2015

SCCM 2012 R2 CU2 Can't Edit WMI Query Code in Report Builder

I first posted this in the SCCM but the issue is not solved so I thought I'd try here in the SQL Reporting forum. Original thread here: http://social.technet.microsoft.com/Forums/en-US/b0a6ca3d-7471-4b49-8447-7403a65c2ec0/sccm-2012-r2-cu2-cant-edit-w

SCCM 2012 R2 PxE can't boot - your pc need to be repired.

Dear All, These days, I upgraded SCCM 2012 to R2 , after that PxE can't boot , and shows a blue screen that your pc need to be repired, same issue like this:http://www.gerryhampsoncm.blogspot.ie/2013/02/sccm-2012-task-sequence-fails-with-bcd.html And

Cannot Edit Universe Query in Crystal Reports.

Hi, We have Crystal Reports 2008 SP5 installed on a Terminal Server where our report developers can go to develop reports. We have a 4 node BOXI R2 SP4 cluster on the opposite side of a firewall, and have opened the firewall ports so that Crystal Rep

SCCM 2012 Deploy --- Error = The software change returned error code 0x87D00324(-2016410844).

Deployment to the client is successful but the error reported within Clients "SCCM Software Center"   The software change returned error code 0x87D00324(-2016410844). Also States on "Status" Past Due - Will be Retired" Can't figur

SCCM 2012 R2 Reports not activate Value button and not showing Visio and Project products

Hello, I have experiencing some problems with SCCM reports 1)  In some of the reports the "Values" button is disabled and because of that I can not select the name of a specific computer, the reports I've noticed that are relating to Specific Co

New SCCM 2012 client machines still getting SCCM 2012 SP1 client not the new SCCM 2012 SP1 CU3 client

Hi, I've successfully (as far as I can tell) deployed SCCM 2012 SP1 CU3 and all my existing clients are showing a client version of 5.00.7804.1400.  But when I setup a new client system recently I noticed that the client version was showing 5.00.7804

SCCM 2012 Report equivalent of WSUS Report

In the old WSUS admin console you could set your display under All Computers (and other computer groups) to show patches that were Failed/Needed/Applied. I found this EXTREMELY useful. I can not find an equivalent within SCCM 2012. Does such a report

How to deploy Photoshop/Premiere Elements 13 with SCCM 2012 r2?

Hi there I want to create a .msi package of Photoshop/Premiere Elements 13 for SCCM 2012 r2. Can me anyone give a tutorial or a tip? thxIf you want to deploy lync by SCCM, you may utilize config.xml to do that. All the things you want to configure, y

App-V 5.0SP2 question with SCCM 2012 CU4 (functionality vs full support with R2)

I understand that for App-V 5.0 SP2 and SCCM 2012 SP1 integration at least CU4 is required but R2 with CU1 for full functionality. I've attached an image from some session that someone else gave me. I have questions after looking at the slide since t

SCCM 2012 secondary server

Hi All, I am trying to install secondary site server from primary site server. All the prerequisites like .NET 3.5, 4, RDC, BITS are installed. Primary site server name is added In the local admin on the server. But still the installation is getting

How many SCCM 2012 consoles are supported

Hello, I have been asked to determine how many SCCM 2012 consoles we can run in our environment. We have a large number of support staff (100+) that need to have access to Remote Tools and possibly some Collections for application deployment. I didn'

SCCM 2012 R2 Report using WMI Query

I am trying to find out if I can generate a report to show which users installed what software using a report in SCCM 2012 R2 and a WMI Query. If not using the reporting within SCCM, then: 1)  is it possible to pull such data via a wmi query 2)  any

SCCM 2012 OSD/MDT TS: Can I set the ComputerBackupLocation to d: (local) durin wim capture

Hi, SCCM 2012 SP1 OSD w MDT 2012 /MDT TS: Can I set the ComputerBackupLocation to d: (local drive) durin OS wim capture? /SaiTechHi, Please see if the article below helps: Understanding How MDT 2010 Automatically Determines a Backup http://www.migee.

SCCM 2012 - how can i make it alert in SCOM if a deployment fails

Can anyone suggest a post or tell me how to get alerts in SCOM when a deployment from SCCM 2012 fails? The situation is we deploy Microsoft patches on a monthly basis to all workstations in the company, I want an alert in SCOM if the deployment fails

Can we recover SCCM 2012 R2 site Servers and SQL DB from hyper V or Vmware VM snapshot

Hi Folks Can we recover SCCM 2012 R2 site Servers and SQL DB from hyper V or Vmware VM snapshot if yes is there any challenges or any document available from Microsoft on Hyper V SCCM VM snapshot recovery.I've made it work and it "should" work.

WMI Corruption - SCCM 2012 - Win7 SP1

Hi all, So we are in the process of switching to Configuration Manager 2012 and we are now having MANY instances of WMI corruption on user workstations. The OS we are deploying is Win 7 SP1. Symptoms: -Keeping users from logging in (heavily delayed o

Installing sccm 2012 error -prerequisites failed sql

Hi While I'm start installing the SCCM 2012 R2 in windows 2008 R2 , SQL version : Microsoft SQL Server 2008 (SP3) - 10.0.5500.0 (X64)   Sep 21 2011 22:45:45   Copyright (c) 1988-2008 Microsoft Corporation  Enterprise Edition (64-bit) on Windows NT 6.

SCCM 2012 SP1 is Running on SQL Server 2012 with NO CU

I am working in an org that has SCCM 2012 SP1, it is and always has been running on SQL Server 2012 RTM, with NO CU installed it seems (judging by the file versions 11.0.2100.60, which are not the same as as documented here http://support.microsoft.c

Sccm 2012 agent not installing with error CcmSetup failed with error code 0x80041013

We have sccm 2012 r2 enviroment , when we deploy client agent to one DC , client agent is not getting install with below error .. I can able to install agent to all the machines except one DC. CcmGetOSVersion failed with 0x80041013 CcmSetup failed wi

Create Global Condition using SCCM 2012 SDK programmaticaly

Could someone please help me in creating some simple Global Condition in SCCM 2012 with SDK. First, I thougth that it will be pretty easy just creating a SMS_GlobalCondition WMI objet instance, but then I found that there is no any information about